Set hsts-include-subdomains to false in nginx ingress


Can anyone help me to set hsts-include-subdomains to false in the config for the nginx-ingress? We are using Rancher 2.4.2.


Kind regards,
Peter Talen

Mmmhm, first post here, not a single answer. :cry:

Please see the docs here


Thanks for your answer. I have added the option to the config map (see first and second part of image) of the project, however it is still not working (see third part of image, tested with I have restarted the ingress-nginx pods. What am I doing wrong?


Anybody who can help me out?

The logs of the NGINX ingress pods will show that it correctly reloaded after the changes. If it errors out, can you try false (without the quotes)

Ok, thanks for the reply, I will check it in the next couple of days.