Can't activate HSTS on Ingress Controller

I’m trying, unsuccessfully, to activate the HSTS in my cluster.
I followed the following doc ( and added the following settings in the Nginx ingress controller configmap:

When I check the headers of my website, I don’t see the HSTS enabled or with website like

Can you help me ?

My config:
Rancher 2.2.8 HA
Ingress version : rancher/nginx-ingress-controller:0.21.0-rancher3


Any idea?

Thank you