Shutting down SLES


Running SLES11sp3 with OES11sp2 and GroupWise 2012sp2

My server started to to become unresponsive and GW stopped responding. So I ran a “rcgrpwise stop”.
Groupwise shuts down and I then ran “shutdown -r now”. The server starts to shutdown various processes and then does nothing.
So I wait a bit, then wait a bit longer (20 minutes) and still no reboot. I “ssh” into the box and try “init 6” and “init 0”, but the server refuses to die.
I then hit the power button and the box restarts. All looks good but GW doesn’t load…I can then see that the NSS volume has not loaded.
I then go into mild panic mode and need to run “ravsui” to verify the NSS pool, which takes 4 hours (It is not a peaceful 4 hours,
cos users start complaining about no mail). I then “activate the pool” and mount the drive with “nsscon”
Then all is good again … until the next time.

So my question is how do I avoid this situation next time and be able to force the server to shutdown without breaking the links to the NSS volume?


John Gill wrote:

how do I avoid this situation next time[/color]

Well, that depends on just what the problem is and that has yet to be
determined. It may just have been a one-time occurrence. It is probably
best to test it again when the server can be down for a period of time.

If it happens again and you can’t find anything obvious when looking at
the logs, You can try asking in the OES forums if you suspect it is
related to NSS or you may have to open a Service Request with Novell
and have them assist with some detailed troubleshooting.

Kevin Boyle - Knowledge Partner
If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below…