SLED 11.3 Initial Review

I have been wrestling with SLED for a couple days straight now and thought I’d share my thoughts to help those who may be in the same area I was

I love SUSE’s installer and have for a long time. SUSE Enterprise installed fast and had absolutely no hiccups. I wish the rest of the Linux community would learn from Novell’s (now SUSE’s, I guess) team and implement something similar Linux-wide. If you are familiar with openSUSE, you will not get lost.

For those new to SUSE, although it can be used simply, the expert Linux guru can access the needed items to do a custom install.

[]Partitioning: You can use the Guided LVM, Guided, or Manual methods of disk partitioning; no surprises here; you can also choose to have it suggest a separate [/HOME] partition, which is always a good idea;
]User Setup: No surprises here, either; however, it is worth pointing out that I was not able to use my first user’s password as the superuser’s password. Fantastic job there! Good security practice; the only caveat I have, though, is to enforce the principle that the superuser cannot have the same password as a regular user; however, with that being said, good job & thank you for taking a good approach.
[]Software: Just as in openSUSE, the user can click on the line just before installation to change the default software packages; a little hint for those who like to select the individual packages: Choose

below the package group list.
]Auto-configure: Again, nothing new for those used to openSUSE; it does seem more solid and did not present any problems during installation.

All-in-all, I am just as impressed with SLED’s installation process as I am with openSUSE’s both of which are similarly designed.


Again, a BIG ‘Thank you!’ to the developers. My wireless card worked flawlessly. And, I mean absolutely flawlessly. openSUSE is the only distribution which had this card working out of the box; however, I had to fix the NetworkManager problem that is common to openSUSE 12.3.

SLED 11.3 is a dream come true in Network configuration. If I were a geek who had nothing better to do than wrestle with drivers, dependencies, or what have you, then, perhaps (and only perhaps), Gentoo or Arch would be the distro to choose; however, I do not want to wrestle with anything, I just want it to work, which SLED 11.3 did wonderfully well.

I tried all the major distributions and several smaller ones and none of them, not even Fedora, configured my wireless card correctly. SLED 11.3 was easier than Windows (a re-install of Windows 8 does NOT have the driver available, I had to provide it after install), it installed on Install; closely in second place was openSUSE 12.3, which just required the NetworkManager fix to see all its network interfaces.


It comes with the standard applications expected of a Linux distribution, with one caveat. They are all now legacy applications. When I say legacy, I mean that they are a couple years behind their current counterparts, if they even exist. For example, I was easily able to install Kompozer, which was not available for openSUSE 12.3.

This could be a problem for some developers; for example, the supplied (read that “supported”) version of python is 2.6.x. I understand why they do not publish an upgrade to 2.7.x, such an upgrade would break dozens of installed packages; however, for industry standard development, python is either the 2.7 flavor or the 3.x; given the issues with certain python modules porting to 3.x (i.e., Twisted), I stick with the 2.7. More importantly, python 2.7 has the capability to import from future to provide an upgrade path to 3.x.

Because I work with and develop in python 2.7.x, many of the Applications I have lately used will not compile. Period. So, no luck there.

Outside of the legacy version issue, every single package I have used (and I’ve tested all the major and most minor ones), has run solidly. No errors, bumps, beeps or issues. Another big plus, in my book.

Desktop Environment

Novell’s developers deserve a HUGE kudo for providing GNOME 2.x! I now remember why I hate GNOME 3.x… with a passion. I miss this lovely DE and am happy to be using it again. It feels fantastic, I have the capability to bend it to my will and it doesn’t feel like a Windows 8 “wanna-be”.

Other than that, it is rock solid and beautifully simple. For those who want a GNOME 2.x experience, this is one of the few ways left to do so; there are other options for a GNOME 2.x-like experience, but few distros offer it as their main DE.


I love this OS. I am surprised that I do, to be honest. The biggest plus is that it is not encumbered with modern Desktop Environment developers’ ideas of “usability.” I guess that SUSE will implement GNOME 3 at some point, I wish they would not, but I am sure they will; however, for now, GNOME 2.x works extremely well.

I do not know if this is the desktop for me. I need to use python 2.7.x for development. I do not care so much for LibreOffice; it is a fine Office suite; however, I think the GUI is clunky-feeling and hearkens back to the Windows 95 era. Personally, I prefer and use the Calligra suite; I know it is a KDE-based application, but I like its look and feel much better. It is not available for any SUSE, open or Enterprise, less than 12.1. Trying to install it from source creates a dependency hell that should not be enacted.

This happens a lot. If one were to try to install modern packages from source, one would find that it is either a daunting task or nearly impossible. The best option, I have found, is to either get source packages from a couple years ago, or to find an alternative.

My Suggestion to SUSE
Drop the “open” and “Enterprise” distinctions, offer support for a SUSE distribution, with the Novell-based packages (which are currently included in SLED and differentiate it from openSUSE) and I would ecstatically pay the approximately $600 support fee per license (at the moment I am looking at 9 desktop systems and 1 server, for one business).

As it is, as much as I honestly like SLED, and respect the developers for an extremely solid OS, the lack of modern packages is darn close to a deal breaker for my purposes.

SLED is all about stability. The idea is you get something that stays mostly the same for years in terms of versions of things. There are many advantages to this though as your comments reflect, much can change during the life span of the a SLED release. SLED 11 GA was released in March 2009. Python 2.7 was still a year away ( GNOME 3.0 was still two years away :wink: ( The issue of included versions of things slipping ever further from the current versions is inevitable in any long term supported distro release. The current version of RedHat Enterprise Linux also has Python 2.6 and GNOME 2, as does Ubuntu 10.4 LTS.

FWIW, Python 2.7.5 builds from source on SLED 11 SP3. I haven’t done any testing with it, I don’t ‘do’ python myself, but it builds and runs:

me@mine:/tmp/Python-2.7.5> ./configure --prefix=/tmp/python27 && make -j 8 && make install
[ much output ]
me@mine:/tmp/Python-2.7.5> /tmp/python27/bin/python
Python 2.7.5 (default, Aug 29 2013, 13:27:03) 
[GCC 4.3.4 [gcc-4_3-branch revision 152973]] on linux2
Type "help", "copyright", "credits" or "license" for more information.

I can’t tell you off hand which packages beyond a default installation are need to be installed to make it build, I expect some packages from the SLE-SDK are required. (Unless you want sources, you only need DVD1. I live in hope that one day that will be explained on the download page. And that if I type that often on the forums it will become so.)

It’s been indicated that SLED 12 will ship around the middle of next year. What that uses as the primary Desktop Environment remains to be seen. The next version of RedHat Enterprise Linux will ship with GNOME 3 but they’re going to use Classic Mode as the primary DE ( I think that’s a smart choice.


I, too, was able to get the 2.7 from source to install, but not system wide. I wanted to update 2.7 on the system in order to use Red Note Book, Calligra Office Suite and a few other programs that rely on the 2.7 version of python (or, the dependencies found in the 2.7 branch).

I did download the SDK, as you suggested, and that helped a little bit; however, having to load my DVD for every package install was tiresome. So, I took the ISO, created a mount point for it and when I needed to install something, it runs off the mount point as a DVD. Much, much faster :).

YaST->Software Repositories->Add there is an option for an iso image in
the list, no need to create mount points etc… If you add the SDK iso
via YaST->Add on products it will add the online repositories and the
iso image as a repository.

If you use the Add on creator, you can add a collection of your own
rpms and build as an iso image to create your own repo as well, good
for updating multiple machines if your not running an SMT server.

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Knowledge Partner - If you find this post helpful and are logged
into the web interface, show your appreciation and click on the