SLES 12 - Drush & composer

I’m trying to install drush 7.x onto sles 12 and having a time of it.

Using the drush instructions I need to install composer first: curl -sS | php

This throws a error: The phar extension is missing - now I’m using the php (5.5.14.x) that came with sles 12 and according to phar is included in php 5.3 and above. php.ini has a [phar] section with only 3 options. No of which seem to restrict it from being seen.

As I’m also using fpm the php.ini is in /etc/php/fpm and I tried the above command with the -c /etc/php/fpm/php.ini with the same results.

Any ideas ?

Looking at the OBS version spec file here;

Looks like it’s just a few files, softlinks and bash completion…

Why not ping the maintainer (see the changes file) and ask them to update?

Do you know if php was compiled/packaged with phar support in sles 12 ?

Looking at the spec file on OBS for php5 it does appear to be enabled, however there is a separate package php5-phar which doesn’t appear to be included in the web hosting extension. Let me check with my SUSE contacts, but may need you to raise an SR, is that possible for you to do if needed?

I tried

Unfortunately the yum file has repos that don’t exist and the package fails checksums. So this was a no go.

[QUOTE=cisaksen;29033]I tried

Unfortunately the yum file has repos that don’t exist and the package fails checksums. So this was a no go.[/QUOTE]
You mean ymp file?

You can manually add the repo and do a refresh;

zypper ar -f "server:php-SLE12"
zypper ref
zypper in drush

Still waiting to hear back on the missing phar package.

Yes I can add the repo manually but I still get the check sum error - basically saying that the package isn’t valid.

I was able to install drush 6.2 using pear

pear channel-discover
pear install drush/drush

But I was hoping to install 7.x

Found the problem with my invalid signature, I was trying to use suse mgr 2.1 with a custom repo - something is wrong with it . If I added the repo directly on the server it worked fine, though it still drush 6.6

Adding the key from the repo should help…

Yes, in my earlier link, ping the maintainer to update?

Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
SUSE Linux Enterprise Desktop 12 GNOME 3.10.1 Kernel
3.12.44-52.10-default If you find this post helpful and are logged into
the web interface, please show your appreciation and click on the star
below… Thanks!