SLES upgrade from 12 SP2 to SP4

Hi All,

I"m trying to upgrade from 12 SP2 to SP4. Our Hana server can’t connect to the internet, so we use smt to deliver the updates. I tried with yast2 migration and i got this error:

Error: Product SUSE Linux Enterprise Server for SAP Application 12 SP will be automatically removed.

When i tried to continue it said i cannot continue until error is resolved. So i tried to run the migration with zypper:

zypper migration, but got this error:

[SMT-http_SERVER_com:SLE12-SP4-SAP-Pool|] Valid metadata not found at specified URL
Please check if the URIs defined for this repository are pointing to a valid repository.
Skipping repository ‘SLE12-SP4-SAP-Pool’ because of the above error.

From the filesystem, i can see that the product folder isn’t mirrored:

SERVER:/srv/www/htdocs/repo/SUSE/Products/SLE-SAP/12-SP4/x86_64 # ll
total 0
drwxr-xr-x 1 smt www 42 Dec 12 19:52 product_debug
drwxr-xr-x 1 smt www 30 Dec 12 19:52 product_source

Yet i can tell that i’m authorized for it from my license on

SUSE Linux Enterprise Server for SAP Applications 12 SP4

I’ve tried to run this command:

smt-repos -p SLES_SAP,12.4,x86_64 which downloaded all the packages, then i mirrored it with smt mirror.

But the product location isn’t downloaded. I deleted the folder structure and tried to re-mirror it, same issue.

I tried to manually add it, but that didn’t work, same error. I tried to de-register, clean and remove cred/repos/serives and then get the new , same issue.

If i remove the product from the smt server, the migration won’t work because the distribution isn’t to date. I checked the forms about the btrfs filesystem, but that’s not the problem.

Thanks in Advance for any tips.


Found the issue. If anyone is upgrading, make sure that in SMT server Manager, you’re repositories are not staged.

I un-selected staging and mirroring, then ran smt mirror again, the files were downloaded and i was able to continue with the migration.