SMT - mirror 11.2 repo on a 12.2 host


I am trying to set up an SMT server to patch/update an offline environment (the smt server will have an outbound connection for a moment in time to sync repos accordingly).

What I am trying to do is use a SLES 12.2 host to mirror an 11.3 repo but seem to be having some difficulty in getting it set up.

  1. Is this even a possible configuration? Or does an 11.3 update repo have to be mirrored onto an 11.3 SMT host?
  2. I see a number of 11.x repos listed when I run smt-repos but not the 11.3 update repo as I would like
  3. I tried to manually add an 11.3 repo into the zypper config but the system seems to disable it automatically.
  4. If the goal is to just mirror the repo, is there an easier/better way to go about this?

I’ve looked over a number of docs but maybe am missing the ‘one’ that will help most, any link to appropriate docs appreciated.


SMT on SLES 12 SP2 is able to mirror all SLE repositories. I am mirroring SLE 11 SP1 to 12 SP3 repositories with mine.
Have you logged in to and checked if the repositories are visible there ?
They are (hidden) under Subscriptions||Base and Extension Products|SUSE Linux Enterprise Server xxx

Best regards