[SOLVED] Convoy-nfs: Failed to allocate instance, bad instance, scheduling failed


#1

As soon as I try to create a service which uses the convoy-nfs driver, I get the following error:

Failed to allocate instance [container:1i84]: Bad instance [container:1i84] in state [error]: Scheduling failed: valid host(s) [], volume [65] must have exactly these pool(s): [3], valid host(s) []

I have used the catalog template to create the convoy-nfs stack. The NFS server is configured on the same machine where the Rancher server runs. The other hosts already mounted the nfs share. It doesn’t matter if I create a volume first or specify the volume name during service creation. I get the same error.
The rancher/server container reports the following:

2016-11-07 16:19:48,206 ERROR [cba5e2f8-0be9-4d83-9843-c7a1658f309b:1760] [instance:85] [instance.start->(InstanceStart)] [] [cutorService-44] [i.c.p.process.instance.InstanceStart] Failed to Scheduling for instance [85]

Rancher version: v1.2.0-pre4-rc6
Convoy-agent: 0.9.0
Docker: 1.12.2


#2

I still have the same issue. Is there really no one who knows what’s up?
I tried to disable the firewall, restart the docker services, the rancher container, delete the convoy-nfs stack and add it again but it still doesn’t work.


#3

Replying to myself again…
I have reverted to rancher v1.2.0-pre3 and set up convoy-nfs with this mount options only: “nfsvers=4”.
Now I can create services wich use the convoy-nfs driver.