[Solved] Digital Ocean Container distribution Droplet auth

Everything I’m finding in search are references at Digital Ocean and Rancher about no current RancherOS availability on DO. However, it’s in their images now. Unfortunately, I can’t access it. After multiple attempts, the same SSH key I use on a dozen other DO droplets fails on the RancherOS droplet. It then asks for a password, but DO droplet settings say it’s unavailable. I’ve tried a few common passwords. Have I missed something, or does the droplet have an issue?

Answer at Digital Ocean:

If you’re using CoreOS, Rancher, or FreeBSD, the username will be core, rancher, or freebsd instead of root, respectively.

Running RancherOS on DigitalOcean is not yet supported


The user is rancher for rancheros, not root (or your name).

mercury:~ vincent$ doctl compute droplet get 83477221
ID          Name       Public IPv4       Private IPv4    Public IPv6    Memory    VCPUs    Disk    Region    Image                   Status    Tags
83477221    vjf-ros                                   2048      1        50      sfo2      RancherOS v1.2.0 x64    active
mercury:~ vincent$ ssh rancher@
The authenticity of host ' (' can't be established.
ECDSA key fingerprint is SHA256:BFNauv/FfSpdf3Lz1bI4kwZNVLJrGk1PV1Vm6zsgWng.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added '' (ECDSA) to the list of known hosts.
[rancher@vjf-ros ~]$
1 Like

I had a bad feeling that I was going to look like a moron when posting this. I even tried emailing Rancher support first to avoid it. They still directed me to the forums. Oh well, I hope this helps someone else avoid the same thing.

I’m in! Thank you!