[Solved] Sudo ros os upgrade no new version of docker


#1

Hi,

I’ve got rancher os running on a bare bone x86 system. I executed a an upgrade from version v1.0.1 to v1.0.4, after the upgrade docker is still 17.03.1-ce but the rancher os was upgrade.

After this is also upgraded to v1.1.0-rc2 but also with this version I’ve still got the 17.03.1-ce docker version.

What do I need to do in order for the docker version to be upgraded?

[rancher@rancher ~]$ sudo ros os list
rancher/os:v1.0.3 remote available
rancher/os:v1.0.3 remote available
rancher/os:v1.0.2 remote available
rancher/os:v1.0.1 remote available running
rancher/os:v1.0.0 remote available
rancher/os:v0.9.2 remote available
rancher/os:v0.9.1 remote available
rancher/os:v0.9.0 remote available
rancher/os:v0.8.1 remote available
rancher/os:v0.8.0 remote available
rancher/os:v0.7.1 remote available
rancher/os:v0.7.0 remote available
rancher/os:v0.6.1 remote available
rancher/os:v0.6.0 remote available
rancher/os:v0.5.0 remote available
rancher/os:v0.4.5 remote available
rancher/os:v0.4.4 remote available
rancher/os:v0.4.3 remote available
rancher/os:v0.4.2 remote available
rancher/os:v0.4.1 remote available
rancher/os:v0.4.0 remote available
[rancher@rancher ~]$ ros os upgrade
FATA[0000] ros: Need to be root
[rancher@rancher ~]$ sudo ros os upgrade
Upgrading to rancher/os:v1.0.4
Continue [y/N]: y
Pulling os-upgrade (rancher/os:v1.0.4)…
v1.0.4: Pulling from rancher/os
88286f41530e: Pull complete
1f4ef0724a0a: Pull complete
74268fde99d0: Pull complete
ed27114da820: Pull complete
8563ab778297: Pull complete
e0e793920bfe: Pull complete
5ca7a1f40c18: Pull complete
49d838fa429e: Pull complete
09bcf6c2d8e3: Pull complete
9749b542b20b: Pull complete
Digest: sha256:bd6c9c816c817350e4486ae093a5827ba6cb08a23ad8363d801fa1a182ef4fdc
Status: Downloaded newer image for rancher/os:v1.0.4
os-upgrade_1 | Installing from :v1.0.4
Continue with reboot [y/N]: y

INFO[0022] Rebooting

After roboot:
[rancher@rancher ~]$ docker info
Containers: 27
Running: 18
Paused: 0
Stopped: 9
Images: 52
Server Version: 17.03.1-ce
Storage Driver: overlay
Backing Filesystem: extfs
Supports d_type: true
Logging Driver: json-file
Cgroup Driver: cgroupfs
Plugins:
Volume: local
Network: bridge host macvlan null overlay
Swarm: inactive
Runtimes: runc
Default Runtime: runc
Init Binary: docker-init
containerd version: 4ab9917febca54791c5f071a9d1f404867857fcc
runc version: 54296cf40ad8143b62dbcaa1d90e520a2136ddfe
init version: 949e6fa
Security Options:
seccomp
Profile: default
Kernel Version: 4.9.40-rancher
Operating System: RancherOS v1.0.4
OSType: linux
Architecture: x86_64
CPUs: 4
Total Memory: 31.32 GiB
Name: rancher.example.com
ID: 5NTZ:32IV:Z3GU:H5YG:OALR:6D2G:AVP3:UB7Y:BW2T:FTOB:DBS6:N6PC
Docker Root Dir: /var/lib/docker
Debug Mode (client): false
Debug Mode (server): false
Registry: https://index.docker.io/v1/
Experimental: false
Insecure Registries:
127.0.0.0/8
Live Restore Enabled: false


#2

I found out that I also had to switch the engine manually. This can be done by using the following command:

sudo ros engine switch docker-17.06.0-ce