some ask tags in AutoYast don't work


in my AutoYast.xml I want to input the Hostname, IP, Network Prefix & Gateway via the ask tags like in :
The problem is, only the Prefix and IP questions will show up during the installation. It’s not asking for the hostname or gateway, so after the installation the gateway is and the hostname is sles-test.
The order of the questions is a bit off too, it’s asking for the prefix first and then for the IP.
Is there something wrong with my config?

Snippet from my AutoYast.xml

220   <general>
221     <ask-list config:type="list">
222         <ask>
223             <path>networking,dns,hostname</path>
224             <question>Bitte Hostnamen angeben</question>
225             <stage>inital</stage>
226             <default>sles12-server</default>
227         </ask>
228         <ask>
229             <path>networking,interfaces,0,ipaddr</path>
230             <question>IP für eth0:</question>
231             <stage>initial</stage>
232             <default></default>
233         </ask>
234         <ask>
235             <path>networking,interfaces,0,prefixlen</path>
236             <question>Netzwerk Prefix</question>
237             <stage>initial</stage>
238             <default>16</default>
239         </ask>
240         <ask>
241             <path>networking,routing,routes,0,gateway</path>
242             <question>Gateway</question>
243             <stage>inital</stage>
244             <default></default>
245         </ask>
246     </ask-list>
247   </general>

268   <networking>
269     <dns>
270       <dhcp_hostname config:type="boolean">false</dhcp_hostname>
271       <hostname>sles-test</hostname>
272       <nameservers config:type="list">
273         <nameserver></nameserver>
274         <nameserver></nameserver>
275       </nameservers>
276       <resolv_conf_policy>auto</resolv_conf_policy>
277       <write_hostname config:type="boolean">false</write_hostname>
278     </dns>
279     <interfaces config:type="list">
280       <interface>
281         <bootproto>static</bootproto>
282         <device>eth0</device>
283         <ipaddr></ipaddr>
284         <netmask></netmask>
285         <prefixlen>16</prefixlen>
286         <startmode>auto</startmode>
287       </interface>
288       <interface>
289         <bootproto>static</bootproto>
290         <device>lo</device>
291         <firewall>no</firewall>
292         <ipaddr></ipaddr>
293         <netmask></netmask>
294         <network></network>
295         <prefixlen>8</prefixlen>
296         <startmode>nfsroot</startmode>
297         <usercontrol>no</usercontrol>
298       </interface>
299     </interfaces>
300     <ipv6 config:type="boolean">false</ipv6>
301     <keep_install_network config:type="boolean">true</keep_install_network>
302     <managed config:type="boolean">false</managed>
303     <routing>
304       <ipv4_forward config:type="boolean">false</ipv4_forward>
305       <ipv6_forward config:type="boolean">false</ipv6_forward>
306       <routes config:type="list">
307         <route>
308           <destination>default</destination>
309           <device>-</device>
310           <gateway></gateway>
311           <netmask>-</netmask>
312         </route>
313       </routes>
314     </routing>
315   </networking>

Also tried pathlist like discribed in but no success

<pathlist config:type="list"> <path>networking,dns,hostname</path> <path>...</path> </pathlist>



It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

These forums are peer-to-peer, best effort, volunteer run and that if your issue
is urgent or not getting a response, you might try one of the following options:

Be sure to read the forum FAQ about what to expect in the way of responses:

If this is a reply to a duplicate posting or otherwise posted in error, please
ignore and accept our apologies and rest assured we will issue a stern reprimand
to our posting bot…

Good luck!

Your SUSE Forums Team