Specify Authorized Cluster Endpoint Port

I’m trying to setup an external load balancer where I’d like to use the same VIP for both Kubernetes API (Authorized Cluster Endpoint) and for Ingress, so I’ve configured my load balancer to forward:

VIP:6443   -> Control Plane Nodes
VIP:80/443 -> Ingress Nodes

However, when I specify my FQDN for my Authorized Cluster Endpoint in Rancher there is no option to specify the port, and it does not accept standard :6443 notation, so the kube-config file generated by Rancher incorrectly points to FQDN:443 instead of 6443.

Is there any YAML option I can use to specify the port? I’ve tried port and fqdn_port without success.

Also, it would have been nice with a radio button like “Use Cluster kube-ca certificate”, so I don’t have to manually paste my kube-ca certificate here, when I don’t terminate SSL in my external load balancer.

Environment: Rancher v2.5.3 with RKE cluster created with “Existing Nodes”