SSH time out while provisioning nodes (EC2)


I’m struggling getting the node provisioning working on AWS EC2. I have a security group which I’ve allowed any outbound traffic to and inbound I have the “proper” port mappings setup and specified the correct region. SSH and HTTPS are allowed from, again, Furthermore “Docker port”, 2376, also accepts from

I initially tried the “ami-0782dcdedcc2aaa11” with the “rancher” user which didn’t work - got the dreaded

handler node-controller: Error creating machine: Error detecting OS: Too many retries waiting for SSH to be available. Last error: Maximum number of retries (60) exceeded, requeuing

I then created my own Ubuntu 20.04 instance and installed Docker 19.03 and added the docker group to the “ubuntu” user. Created an AMI, launched an instance based on this AMI and tried to ssh using the “ubuntu” user. No problem here ssh:ing into the instance.

However, when trying to use my new AMI based on Ubuntu 20.04 for provisioning (node provisioning through Rancher) I get the same ssh-timeout error as with the RancherOS based AMI!

I use Rancher Server v2.51 running on docker (dev purposes) and, as mentioned above, Ubuntu 20.04 together with Docker 19.03 as the provisioning AMI (ubuntu SSH user).

What am I missing out here?