State lost after upgrade

I have a few low-tech boxes for experimenting with only a single USB flash drive. Installed RancherOS from a temporary flash drive using simply ros install -d /dev/sda -c cloud-config.yml, with a pretty basic cloud-config, with just hostname and a ssh key in it. I was happy using 0.4.3-RC2 with this setup, until I tried to upgrade to 0.4.3 final.
Everything went smooth with ros upgrade until I the box rebooted and I tried to ssh into it: after a few unsuccessful attempts I noticed that everything is reverted back to defaults: the box had the default hostname, a different dhcp client-id, ssh keys and so on. Tried to re-install RancherOS 0.4.3 from scratch, with the same flash-drive to flash-drive method, but after rebooting without the flash-drive used as installation source, I had the same issue, no configuration was persisted at all, I got default host name, etc.
I’m a bit stuck here, am I doing something wrong? Is there something related to configuration persistence changed since 0.4.3-RC2? (Haven’t tried to re-install RC2 from scratch yet).

I tried to play with cloud-config.yml with various settigns, but had no luck.

The default busybox console is ephemeral. You probably want the Debian or Ubuntu ones:

Hi Vincent. I tested previously in ubuntu console. If I modify something in /etc/modules directory. After upgrade, that change lost, is this a expect behaviour?

@liyi If you are in the ubuntu console, changes in etc/modules should be persisted after upgrade.

@denise hmm, I will re-test to see if it is the case. How about /lib/modules? Changes there is supposed to list, right? I have tested many times, that directory is always overwritten.