Stuck on provisioning

I sucessfully installed rancher2.0 and tried adding a custom cluster.
With the default options selected I got the docker run command to execute on the 2nd code which can access the 1st node where rancher is installed via pings.

when I run the docker run command provided by rancher, the 2nd node does register on rancher nodes section within the cluster but it doesn’t get provisioned at all. when I did a docker logs I got that it’s waiting to be provisioned.

How do I ensure that it’s not stuck on provisioning ?

Thanks in advance.

When you create a custom cluster, the Provisioning state should say:
Waiting for etcd and controlplane nodes to be registered; waiting for etcd and controlplane nodes to be registered

That means that you need to add an etcd and a controlplane node (or combined on one node), if you want to run workloads, you also need to add a worker node (or combine).

Combining node roles is OK for testing but not recommended for running production.

This is based on the info supplied, if this is not the solution, please provide more information like the OS and Docker used and the actual logging.

1 Like

Is there an advised minimal configuration for production?
Also with the placement hints (where put what)