SUSE Upgrade SLES 15 SP3 to 15 SP5 error zypper migration

Dear friends, please your professional help.

I am in the process of updating an instance in AWS.

  • I have already migrated from SUSE 12 SP5 to 15 SP1 with “SUSE Distribution Migration System”. okay
  • Once migrated, update SUSE 15 SP1 to 15 SP3 with “zypper migration”: OK
  • When performing the online Upgrade from SUSE 15 SP3 to 15 SP5 with “zypper migration” I have problems.
    Dropbox - 1.jpg - Simplify your life

“SUSE_Package_Hub_x86_64:SUSE-PackageHub-15-SP5-Backports-Pool|plugin:/susecloud?credentials=SUSE_Package_Hub_x86_64&path=/repo/SUSE/Backports/SLE-15-SP5_x86_64/standard/] Valid metadata not found at specified URL”
When the error occurred, a Roolback of the steps was performed.

I already found some solutions for this error.
My big problem is that when I run the “zypper migration” command again it no longer gives me the option to update again to SUSE 15 SP5, but instead it directly shows me “15 SP6”. It’s as if in some cache the system thinks it’s already on SUSE 15 SP5, but really I’m still on 15 SP3.

I run everything, without being able to “reset some buffer where zypper migration” still thinks I’ve already gone to 15 SP5.
SUSEConnect --cleanup
registercloudguest --clean
rm -f /etc/SUSEConnect
rm -f /etc/zypp/{repos,services,credentials}.d/*
rm /var/lib/cloudregister/*
rm -rf /var/cache/zypp/*
sed -i ‘/^# Added by SMT reg/,+1d’ /etc/hosts
registercloudguest --force-new
SUSEConnect --rollback

Please help me see how I can tell zypper that I’m still on SUSE 15 SP3 and need to upgrade to 15 SP5.

Thank you so much.

Please help with this problem. It must be a very simple solution but I still can’t fix it :smiley:

So when trying to migrate from SLES 15 SP3 to SP5 you received the error re SUSE Package Hub. How did you roll back?

What does “rpm -qa release” report?