turn off animation and change the background to a solid colo

This customer is running MS Windows Terminal Servers, and their users connect MS Terminal Server from MS Windows XP(via mstsc). Each connection only consumes around 32-40 Kbps.

We started a POC to replace their MS Windows Terminal Servers with SUSE Linux 11 SP 3 + xrdp ver 0.4.x(as a terminal Server), and found that each rdp connection from XP machines starts consuming 280+ kbps, which way too much comparatively.

I complained about the high bandwidth utilization when connecting the “xrdp server” with one of the xrpd developer, and he respond me:
MS always turns off animation and changes the background to a solid color, etc
when you are in an RDP session. Linux desktops don’t usually do that.
So when you compare bandwidth, you need to make sure you are comparing
apples to apples.[/color]
</xrdp developer response>

how do we turn off animation and change the background to a solid color in SLE 11(GNOME). ?

Disable compiz via the Control Center -. Look and Feel → Desktop
effects. For the background either right-click on the desktop and
change the background or via Control Center → Look and Feel →
Appearance and click on the background tab.

Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE 13.1 (Bottle) (x86_64) GNOME 3.10.1 Kernel 3.11.10-11-desktop
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below… Thanks!

I think the closest to ‘turn off animation’ is probably to make sure Desktop Effects are not enabled. You can do that in Control Centre, there’s a module called Desktop Effects. What it actually does is switch your Window Manager between metacity (disabled) and Compiz (enabled) which can do lots of whizzy effects like transparent windows and the rotating cube for virtual workspace switching.

You can find the option to change the Desktop background via Control Centre too. Or by right clicking on the Desktop and selecting ‘Change Desktop Background’, just like in Windows XP/7, but with slightly different words :wink:

its a SLES 11 SP 3 server, and desktop effect are part of SLED only.
we also tried changing the wallpaper to a very basic one without any luck.

We tried openSUSE 13.1 with LXDE(rather GNOME) and found that it consumes far less bandwidth then GNOME(openSUSE 13.1 with GNOME was also consuming too much bandwidth as it does with SLES11SP3)

So we are pretty much convinced that GNOME/KDE is the main issue, and using any light weight desktop environment like LXDE is the solution here. But SLES 11 SP3 does not ship with LXDE. Also icewm is way too simple/old and is out of question here.

So please help me installing LXDE on SLES 11 SP3. which openSUSE version should be best to use as a repo for installing LXDE atop SLES 11 SP3 ?