Ubiquity stuck at "initializing"

I tried deploying a service to Ubiquity using the “Add Host” wizard.

The service downloaded and started fine (the logs confirm), but got stuck at “initializing”.

It had a health check set-up port 4000, for a simple /ping request.

I’m wondering if that’s the issue. Does Rancher link containers through private networking (how Docker Compose/Swarm can now work), or does it try the health check based on publicly accessible ports when the container is run outside of the host network?

Flipping back to AWS for deploying within the same VPC worked fine.

Health checks are over the private overlay network. The healthchecks run on 3 hosts (other than the one the container is on, if n > 3) and hosts have to be able to communicate with each other on the overlay network, which means opening ports 500/udp and 4500/udp between the IP addresses shown in the UI for each host.

AFAIK ubiquity defaults to wide open, so I’m guessing your problem is that you still have AWS hosts and they cannot reach the Ubiquity one or vice versa.

Thanks, makes sense. I didn’t realise the health checks were distributed – good to know.