UI dashboard missing 'local' cluster after upgrade to 2.6.8

After upgrading to my air-gapped HA RKE v2.6.4 to v2.6.8, the ‘local’ cluster no longer appears on the /dashboard/home page.

I can see the cluster by navigating to /c/local, and it also shows up under /g.

Perhaps related, the rancher logs show:

[ERROR] error syncing ‘local’: handler provisioning-cluster-create: failed to create fleet-default/local provisioning.cattle.io/v1, Kind=Cluster for provisioning-cluster-create local: admission webhook “rancherauth.cattle.io” denied the requeset: cluster name must be 63 characters or fewer, cannot be “local” nor of the form “c-xxxxx”, requeuing

I also verified that hide-local-cluster is set to false via the /v3/settings endpoint.

Am I missing the intended behavior of the ‘local’ cluster now, or is this a bug?

I think I figured out what’s going on. Migrating the local cluster into the fleet-default workspace seems to break the Rancher UI – and the local cluster will no longer appear.

Opened a bug. #39202.