Unable to mount rancher-nfs storage

Hi there,
since Rancher 1.3.0 i am not able to mount NFS Storage from my Synology NAS NFS.

It was kinda simple with older rancher version but now all i get is:
(Expected state running but got error: Error response from daemon: chown /var/lib/rancher/volumes/rancher-nfs/data: invalid argument)

There is a Folder “data” created on my synology and its shown in rancher under storage but its always detached.

I tried many suggestions from this forum but nothing works.
i tried different nfs options (even nfsvers=3)

And yes i am able to mount it manually so i goes it must have something to do with rancher-nfs or its kinda container permission thing maybe ?

Any help is very appreciated!

1 Like

Any update about this issue ?

I have exactly the same problem here :frowning:

No sorry, NFS Driver doesn’t work with my Synology NFS.
Maybe its Rancher-NFS or Docker Engine or DSM Update or all together - i don’t know.

The error Message is useless and i haven’t found any clue so far.

I also tried another NFS Server with the same results so i gave up.

Switched to host volumes meanwhile - i don’t think Rancher-NFS has a bright future if it works like this.

Issue is tracked at https://github.com/rancher/rancher/issues/7334

The workaround for now is to specify no_root_squash for any export to be consumed by rancher-nfs.

i thought i’ve tested “no_root_squash” setting also but ok i’ll try that again