Upgrade to SMT under SLES11SP3 fails

We recently upgraded our SMT mirror server to SLES11 SP3 from SP1. SMT no longer works, as it hangs when running smt-sync. There’s no log output and it won’t progress. I found this link for upgrading SMT’s MySQL database: https://www.suse.com/releasenotes/x86_64/SLE-SMT/11-SP3/ - I followed the steps in the Update section, and it still does the same thing.

I also tried to run the “SMT Server Configuration” in YaST. It looks like that we have some repos no longer in SCC, and if I test the connection to SCC, it fails (maybe that’s why it thinks the repos aren’t there anymore). If I change over to using NCC, the test succeeds, but when I click on the Next button, it performs the steps:

-Adjust SMT Configuration
-Adjust Database Configuration
(prompts for root password for SQL, I enter it)
It fails on the next step “Migrate the Customer Center”. The error that crops up is “Error. Changing the customer center back-end failed” and the rest of the steps do complete. The only related error I can see in the Y2log is “Not Connected to SCC”.

SMT was working prior to the upgrade two weeks ago. There is no local firewall package running, but there is an external one, which, iirc, is supposed to allow all access to the novell.com domain over http.

Any ideas as to what I can look for?

BTW, if I run smt-mirror by itself, it will actually connect do the repos I want and update them.

Which version of SMT is installed?

rpm -q smt