I am actually following the below steps to update my SLES 11 SP3 to SP4.
zypper addrepo --check --refresh --name 'SLES-SP4' #REPOURI zypper repos --uri zypper refresh zypper dup zypper pd -i
the zypper dup is showing below problems:
Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command. Loading repository data... Reading installed packages... Computing distribution upgrade... 5 Problems: Problem: nothing provides python-m2crypto needed by python-pywbem-0.7-18.104.22.168.x86_64 Problem: nothing provides yast2 >= 2.17.140 needed by yast2-network-2.17.210-3.3.x86_64 Problem: nothing provides satsolver-tools = 0.17.9 needed by libzypp-9.38.8-0.8.3.x86_64 Problem: nothing provides satsolver-tools = 0.17.9 needed by libzypp-9.38.8-0.8.3.x86_64 Problem: gcc43-4.3.4_20091019-37.3.1.x86_64 requires libgcc1 >= 4.3.4_20091019-37.3.1, but this requirement cannot be provided Problem: nothing provides python-m2crypto needed by python-pywbem-0.7-22.214.171.124.x86_64 Solution 1: keep obsolete python-pywbem-0.7-6.13.x86_64 Solution 2: break python-pywbem-0.7-126.96.36.199.x86_64 by ignoring some of its dependencies
I tried the Solution 1 for all the problems which is keeping them.
and the upgrade steps went fine.
But when I check the version using: zypper pd -i
it still displays as SLES 11 SP3.
What steps I am missing here?
Are the above problems preventing Upgrade?
Please help me on this, if somebody has faced the same problem?