Weird (bare metal) install error

Hi all,

I have the following error when installing RancherOS to a bare metal Dell T20:
Until the install command, no problem and then :

[rancher@rancher ~]$ sudo ros install -c cloud-config.yml -d /dev/sda

INFO[0000] No install type specified…defaulting to generic
Installing from rancher/os:v1.0.0
Continue [y/N]: y
INFO[0002] start !isoinstallerloaded
mount: mounting /dev/sr0 on /bootiso failed: No such file or directory
ERRO[0002] tried and failed to mount /dev/sr0: exit status 255
INFO[0002] starting installer container for rancher/os:v1.0.0 (new)
Installing from rancher/os:v1.0.0
time=“2017-05-15T18:36:59Z” level=info msg="start !isoinstallerloaded"
time=“2017-05-15T18:37:13Z” level=error msg="mountdevice exit status 1"
time=“2017-05-15T18:37:13Z” level=error msg="formatAndMount exit status 1"
time=“2017-05-15T18:37:13Z” level=error msg="error layDownOS exit status 1"
time=“2017-05-15T18:37:13Z” level=fatal msg=“Failed to run install” err="exit status 1"
FATA[0016] Failed to run install err=“exit status 1”

The target disk is empty and both the source USB iso and network seem to be fully available?
A few month ago, I did a similar install w/o any issues on the same machine. Here, I tried with 1.0.1 and 1.0.0.

Any ideas what could be going wrong here?


I wonder if the disk was already partitioned - this is not the first report where the mountdevice has failed. I’ll poke around.

I also read something about this and deleted all partitions from the target disk (fdisk). Should that solve the problem or is there something even more radical to do?