Xip.io dns not working

I have used AWS ec2 ubuntu instance for running rancher 2.0 and tried to deploy the sample application following the documentation. I created the workload and added the load balancer. I was presented with the dns name as xip.io i.e ingress.default.<private_ip>.xip.io but when I tried to access this url in the browser it is not accessible. I have opened the ports 80 and 443 and also the random port for this url.

Can anyone help me in this please?
Thank you

If your nodes are in AWS, but using private IPs, then you won’t be able to access them directly. Do you have a VPN connection into your AWS instances?

Hi shubbard343,

No I do not have any VPN connection onto my AWS instances. You are right as the DNS always takes the private IP of the aws instance. Next I tried creating cluster in aws with the rancher itself and I aws able to get that.

But is there any way I can get public ip in the DNS using custom cluster with aws instance.

Thank you

Can’t you set up you NLB (or ALB) with a public ip ?