1.6.17 adding host files due to UI:hetzner

We have been using Rancher v 1.6.x with the Hetzner Cloud host driver for creating new hosts. That worked really well but for probably unrelated reasons, Rancher Server was periodically hanging on us, requiring me to kill, remove and restart the rancher server to get it working again. I upgraded to the latest stable version 1.6.17 hoping it would resolve the issue with Rancher server going down, which it seems to have done, however now we cannot add any hosts (regardless of whether the environment was using the hetzner driver. Any time I try to add a host I get this error:

Error
Error loading custom driver UI: hetzner

Reload to try again or log out

I don’t have any idea how to resolve this and I can’t find any hints from googling around. Can anyone help?

1 Like

For future reference:

To fix it I went into admin panel, machine drivers and saw there was an upgrade available for the hetzner driver
applying the upgrade fixed it. It was very hard to discover this, so hopefully the next person getting stuck with this will see this message.

For those working with the Hetzner machine driver, you may also want to check out the git repo for it:

1 Like