500 internal error when trying to add environment


#1

I’ve been playing with a new installation of Rancher and simply tried editing several environments. I have enabled github authentication, I created two new environments, I added two github users for one environment and another user for the other environment. Then I deleted these both environments and I renamed the default environment to something else.

Not sure what happened exactly, but now, whenever I try to add a new environment, I get a Internal Server Error (500). I’m not sure even sure how to debug it. Any ideas where to begin?

I’ve also disabled github authentication, but it doesn’t work either way.

I’m using rancher 1.6.25 on a digital ocean droplet on Ubuntu 18.04. I installed docker using this command:

curl https://releases.rancher.com/install-docker/18.06.sh | sh

And started rancher like this:

sudo docker run -d -v mysql-data:/var/lib/mysql --restart=unless-stopped --name rancher16 -p 8080:8080 rancher/server


#2

I think I got ahead of myself a little bit. It seemed to have been related to the fact that it was OOM. I resized the RAM, restarted the vm and now it works as expected.

Thanks :slight_smile: