After offline upgrade from SLES 11.4 to 12.3 I cannot boot

I ran the offline upgrade from SLES 11.4 to 12.3 - that far it worked but now I have this very tiresome issue:

It is a VM installed on XenServer 7.5 and I cannot boot the VM. XenServer aborts with

[FONT=Courier New][COLOR="#FF0000"]Internal error: xenopsd internal error: VM = xxx; domid = 29; Bootloader.Bad_error [Errno 2] No such file or directory.[/COLOR][/FONT]

Good, may be this is a XenServer issue but I want to assure it isn’t SLES.

I can start the VM when I start the VM in the [COLOR="#008080"][FONT=Courier New]Recovery Mode[/FONT][/COLOR] and there I select the first option [COLOR="#008080"][FONT=Courier New]Boot from Hard Disk[/FONT][/COLOR].
Isn’t it strange?

I have the feeling it cannot be that much but it should be solved because I cannot always start this VM this way.

May be the problem is that the SLES 11.2 VM was originally created 4 years ago on a XS 6.2 with a SLES 11.2 template and now the template has a wrong entry regarding the boot loaded which changed due to the upgrade to SLES 12.3


It was a XenServer problem. I had to unset the [FONT=Courier New][COLOR="#FF0000"]PV-bootloader-args[/COLOR][/FONT] VM parameter with this command:

[FONT=Courier New][COLOR="#008080"]xe vm-param-set uuid=*** PV-bootloader-args=[/COLOR][/FONT]

AAEBHolding wrote:


It was a XenServer problem. I had to unset the PV-bootloader-args VM
parameter with this command:

xe vm-param-set uuid=*** PV-bootloader-args=[/color]

We appreciate your providing the solution. It will help others who
encounter this issue.

Kevin Boyle - Knowledge Partner
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below this post.
Thank you.