Hi All,

I’m Using SLED11-SP3 32 bit with gnome.

Recently I’ve tried to install Anjuta, but failed for the “glib-compile-schemas”, it’s not found.

Can anyone tell me, how do I install that, or is that possible to install Anjuta on SLED11SP3 at all.

Thanks. states that the requirements to install Anjuta 2.x are, amongst other things, GTK+ 3.4 or later which SLED 11 SP3 doesn’t have. You can’t update the GTK version without causing all kinds of problems. that I’m fairly certain the page is supposed to say “requirements to install Anjuta 3.x are” not “requirements to install Anjuta 2.x are” because the current version of Anjuta is 3.x not 2.x and Anjuta 2.28 will install on SLED 11 SP3 (SLED 11 SP3 has GNOME 2.28).

If you don’t already have it get the SLE 11 SP3 SDK from

Then get following packages from openSUSE 11.2.

Save them all in to a directory on their own then use

$ cd /where/you/saved/them $ zypper in *rpm
and zypper will install required dependencies from the SDK.
Note I’ve only tested this on 64bit and maybe there’s a better way :wink: (Searching for Anjuta at didn’t show any packages for SLED)


It worked