Auto mount lvm volume after reboot


I am a noob with RancherOS, plus maybe a noob with containers too, and want to learn and play around.

I have a microserver with 1x32GB USB thumb drive and 4x2TB disks.

I have installed RancherOS on my 32GB USB thumb drive.

now I want to create a raid partition of some kind from the 4x2TB disks. I have tried zfs and followed the article “”, but on reboot, the zfs volumes do not mount. I googled and searched and tried various scripts, to no avail, so, gave up on that.

next I tried software raid, but as i didn’t understand that too much, I gave up on that too.

now i want to try LVM, and, as far as i can tell, it is natively supported, so i created a lvm (/dev/vg_pool/Data formated it with ext4, and mounted it at /mnt/data. i followed the advice at “” and used ros config to set the mount, then rebooted. however, the volume did not mount. running a lvscan showed the volume as inactive. i have to manually activated it, and mount it, and the world was good.

what i have trying to do is ultimately move my default docker “folder” to /mnt/data so that i will have a lot of disk space to run and play with various containers.

any ideas or articles that i can be pointed to will be greatly appreciated.

maybe i am going about this the wrong way?