Blacklisting sp5100-tco: Watchdog Hardware disabled in openSUSE 15.4 Leap

When I boot openSUSE 15.4 Leap I get the following message:

“sp5100-tco: Watchdog Hardware is disabled”.

in openSUSE 15.3 I got this same message and I simply went over to /etc/modprobe.d and simply blacklisted it:

blacklist sp5100-tco.conf
“blacklist sp5100-tco”

…and the problem went away. So in 15.4 the same problem occurred and I did the same thing and the problem did NOT go away – then I read the README file and discovered that all the blacklisted files in 15.3 had now been moved to /lib/modprobe.d, and now if you need to blacklist something you first go to /lib/modprobe.d and copy to /etc/modprobe.d where you are now suppose to edit the file – only there is no blacklist sp5100-tco.conf file in /lib/modprobe.d. So I decided to create such a file to go along with the one I created in /etc/modprobe.d. Re booted the machine and the problem is still there.

Next I ran /var/log messages and found the line : “sp5100-tco sp5100-tco: Watchdog hardware is disabled” making me believe that this is a hardware problem, and all I need to do is somehow ENABLE the Watchdog. But I found nothing.

So… here is the hardware:

An ASUS Prime X570 Pro Motherboard; an AMD Ryzen 9 5900X CPU; 2 32 GB SIMS (64 GiB) of GSkill Trident Z Neo 3600 MHz Memory, and Corsair MP 600 1 TB 4.0 Gen. NVMe drive. The OS is openSUSE 15.4 Leap.

So the 3 questions that need to be answered are:

  1. Can I somehow Blacklist the sp5100-tco file like I did in openSUSE 15.3, and if so HOW?

  2. If this is a HARDWARE issue how do I ENABLE the Hardware WATCHDOG so it will get up and “bark”, or allow me to “put it to sleep”.

  3. Do I need to have or worry about this sp5100-tco: Watchdog Hardware being disabled?

I am kind of surprised that SUSE did not create a pre-configured blacklisted file just like the other dozen or so that now reside in /lib/modprobe.d given that this sp5100-tco seems to be a fairly common problem.

Any help you can provide to help me SOLVE this problem would be greatly appreciated. I had no problem creating the file blacklist sp5100-tco.conf. but I used the “touch” command to create it, while I noticed that other people used the “cat” command. Right now I am at a loss to figure out what – if anything – I did WRONG, that would cause this problem.