boot option in grub missing in SLE 12


we can boot our SLE11 systems to a non-default runlevels via “boot options” parameter.
similar option is missing in SLE 12, and one have to press “E” then append the “target” on linux/kernel line.

My question here the old(nice/fancy) option to boot in different runlevel/target is not available in SLE 12, or am I missing something, please guide.

The change from sysvinit to systemd and to grub2 :wink:

AFAIK, at present you need to edit as you discovered…

You can set the target for the next reboot via;

systemctl set-default (runlevel 3)
systemctl set-default (runlevel 5)

Or use the isolate systemd option to switch.

Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
SUSE Linux Enterprise Desktop 12 GNOME 3.10.1 Kernel 3.12.28-4-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below… Thanks!