[Bug] change hostname and debian issue

Hi all,

First of all I must say that for a preview it’s already a great job.
I’m using Rancher since a while now (in my personal infrastructure for now as a poc).
I was impressed by the job done for the v2.
So I migrated all my initial setup to this preview and everything went really fine.

I was trying to setup telegraf and I find this new feature : setup container hostname to host (really handful for what I wanted to do). But this option is not working for now. I click on it and then upgrade my app after that when I edit it again it’s revert back. I can’t make it work (again it’s a little bug).

The other thing I found is that my debian can’t no longer deploy app. Indeed everything works fine when I add it to my cluster but when I try to launch an app it keep restarting with an error :
Error on statfs() system call for “[…]” : permission denied .

I’ve tried with debian 8 (jessie) and after that upgraded it to 9 (Stretch) and multiple docker version (1.12.6 like my ubuntu or docker-ce 17).

Thanks again for your work and feedback.

The hostname_override is covered in https://github.com/rancher/rancher/issues/10059

Regarding the app deployment, I will need more specifics what app and on what host? I just deployed Ghost on Debian 9 with Docker 17.06.2 and I didn’t get any error.

Let me know.

Hello @superseb.
Thanks for the answer indeed I did not check issues sorry for that.

For the app I tried to deploy on a Virtual Machine running Debian 8 Jessie but it was failing (with rancher and cattle it was working). The application was in this case a Prometheus Exporter.
After this failing I tried to upgrade my server to Debian 9 Stretch but I had the same issue.
Also tried a lot of Docker version but maybe I’ve done more bad than good by doing this.
I’ll try to wipe out all trace of Docker and install you version.
I’ll let you know if that’s better.

Thanks again,


Sorry for the delay.
So I’ve tried several changes but the problem still remains. Maybe it’s linked to the app I’m trying to launch because I’ve seen it on an other container (Ubuntu).
Thanks for your help.

If you can describe the steps I can execute to reproduce, I can take a look.