Cannot get Rancher GUI to show up

I have been trying all morning (after multiple machine wipes) to get rancher working again. Earlier it was but it suddenly stopped showing me the GUI and gave the familiar Traefik 404. I don’t know where or how it went from Nginx to Traefik, but it’s not working anymore. I check the listening ports on the load balancer machine and they are not even listening. The rancher pod shows that IT is listening, but somehow it’s not telling docker to listen and helm seems to hide it’s activities in docker so I can’t see what’s going on there. Everything else looks good, I have two master nodes and three agents (all K3S) but when I do the helm install of rancher everything spins up as it should but it just won’t open any ports. I tried port forwarding with kubectl and that actually worked but I don’t want to run it like that.

Never mind, I figured out what happened. In very fine print where you prepare to deploy the helm chart, there is an “Adding TLS Secrets” link that I missed, so those certs were not ingested and it was a huge mess. You got watch out for that fine print.