Did Rancher stop supporting Rancher?

Hi,

I’m trying (very hard) to install Rancher 2.6 on a Linux machine - I’ve tried Docker Single Node install, I’ve tried Helm install and I’ve even tried your Quick Start DigitalOcean Terraform script.

You would have thought it would be easy to spin up a Docker image… But no. It doesn’t work. Container keeps crashing and throwing a bunch of Errors.

Oh heck… a very nice detailed guide for a helm install? HAS to work! But no… Pods keeps restarting. Won’t boot. Dies after a while, trying to deploy.

Aaahhhh… Oh wait wait wait… A TERRAFORM script to automatically deploy a DigitalOcean VM and install rancher for you!? I mean… If THIS doesn’t work, THEN… what?? RKE version not supported???

… I give up!

I really want a rancher server setup to just play around with… But seems like everything I’m trying to do here just doesn’t want to work. These are your guides… Your “Get Started with Rancher in 2 Easy Steps”… Your automated deployment pipelines/scripts? Why does it have to be so difficult to just spin up a rancher server and get going - even for development/testing purpose?

I’m sure that if I sat down and spent a few more hours and watched a bunch of YouTube videos, I would get it up and running… But as a Senior Software Developer, I find it weird that there seems to be SO many errors / bugs in your 2.6 version. And just from looking through your community in here, it seems like I am not the only one.

So… Simple question: Did you stop supporting your own product, or what is going on here?

It was several months since I was doing my poking around on installing Rancher, and I was trying to do things like leave SELinux enforcing that I expected to bite me, but from what I saw a lot of the 2.6 docs had never been updated from 2.5 and a few other places where the docs were wrong. Sad to hear they never got them updated.

You can get more responses to issues from Rancher folks on their Slack than here, though something vague is less likely to get replies.

One thing I can say about 2.6 is that it’s apparently a new rewrite of the UI at least and I think some of their backend APIs and I think that the first 2.5 version was when Rancher was separate but the first 2.6 is after SUSE bought them. I’m new to Rancher with 2.6 but from what I gather with Q&A & complaints on Slack I think 2.6 is trying to bring Rancher more towards 100% FOSS with support sold and get away from some more niche functionality it had before (some of which was apparently quite popular). Additionally K3S & RKE2 are very different architecture from RKE1 but are still labeled as “Tech Preview” when you deploy from the UI, so I’d imagine getting that smoothed out is high priority too. It’s my hope a large part of this is growing pains that they’ve just got their fingers stuck in bigger holes in the damn at the moment and they’ll get to fix some of the docs and initial experience aspects later.

Side note - I did eventually get Rancher installed on CentOS 7 with SELinux enforcing (though firewalld had to remain off), and after going through the debugging hassles with SELinux the time I tried a quick vanilla install just to document for another team to get a quick instance up took me ~6 hours including re-imaging all my VMs and getting the documentation done, so it did finally get to work but just had a higher learning curve than it seems like it should.

Hi,

It should be as simple as installing a new machine (Ubuntu 18.04 in my case) run the docker install command from Rancher, and create a cluster.

curl https://releases.rancher.com/install-docker/20.10.sh | sh
sudo usermod -aG docker YOURUSER

Source: Rancher Docs: Installing Docker

after that, reload your terminal, you should now be able to run docker without sudo.
From this point, it should be just pasting the docker command to run rancher and/or kubernetes.

docker run -d --restart=unless-stopped \
  -p 80:80 -p 443:443 \
  --privileged \
  rancher/rancher:latest

More info can be found here: Rancher Docs: Installing Rancher on a Single Node Using Docker

I completely agree… It should be that simple! :slight_smile:
But it’s not…

I’ve tried now with different versions of Ubuntu & Debian, I’ve tried with different versions of Docker, and I have tried Docker install, Helm install etc.

All of them gives me some kind of error.

I got it to work using the Terraform script for DigitalOcean, after a while (and then not really). I managed to get it to spin up the rancher droplet, but the worker droplet didn’t want to. But I just killed the worker droplet, since I just wanted rancher ui for now (on a single node)… So… It still didn’t work as it should, but I got what I needed…