Cannot view logs of pods


I have a Rancher 2.6.5 instance on which I cannot see logs of any pod when using the default “admin” account. The websocket is opened and I can see load on the network as well as the browser. Albeit no logs are displayed. Working on a shell of the pod/container does work.

When using a different user (cluster admin privileges) on the same instance all is working fine.

How can I reset the settings of the “admin” - user? I reckon the cause might be an accidental misconfiguration of the logging output.

Thanks in advance!

The issue apparently appears when changing the display settings of log viewer.

I played around with the settings (disable/re-enable wrap lines, set to 10k or 100k lines) and the viewer stopped showing the logs. The whole bar at the bottom is gone.

I removed the user account completely (removed it from “Cluster Members” as well as removed it in “Users & Authentication”) and re-created it identically. Now I can see the logs again!

  • Where are the settings for that user account stored?
  • What havoc will I cause if I do that with the Default Admin?

This is a known issue that will be resolved in 2.6.7. The root cause was a bad user preference which once cleared unblocks the log. There’s a couple of workarounds described here and here.

1 Like

Thank you very much @RichardC ! The workaround did the trick for me.

Ok, that value looks broken. Can you try navigating back to <your rancher url>/v3/preferences/logs-range , pressing the delete button on the right of the page and then send request in the modal that pops up. If you then go back to Rancher and try streaming logs again it should work