Can't connect to workload as described


#1

Following the quick start guide, I’m still not able to connect to the nginx based workload as described in the guide. I noticed that Shannon had the same problem in the meetup a couple of weeks ago. Is this going to be fixed soon?


#2

I don’t know where specifically that demo is, but my first guess would be you’re on AWS (or similar) and inbound access to the port is not allowed in the security group, so the service is there but not reachable. The default range for node ports is 30000-32767.

We are adding 80/443 for Ingress to the default security group for AWS, but not the nodeport (AFAIK).


#3

Hi,
I have the same issue even if the ports are open on AWS.
I have tried httpd workload.

  1. when I run : sudo docker ps | grep httpd
    I see that there is no port mapping.

  2. when I start manually an httpd container on any port, for example ’ sudo docker run -p 60000:80 httpd’ everything is working, i.e I can access the port 60000.

I think that there is an issue on port mapping.

thanks


#4

Hi Vincent,
I’m following the demo in the quick start guide, using the GKE environment. Everything seems to work exactly as described (accounting for minor tweaks due to changes in the varying Beta releases), but the workload still remains unreachable.


#5

So again, ports need to be open and are not necessarily that way by default. The default GKE behavior does not expose anything on the actual nodes and only publishes 80/443 for the Ingress controller (on a separate IP)


#7

So, is there an additional step that should be added to the tutorial for GKE? There’s already GKE specific notes regarding Node Pools.