can't partition Intel BIOS RAID disk with autoyast

I have 16 super micro machines that all came with Intel RSTe BIOS RAID, and I am trying to install SLES11 SP4 on them with autoyast. However, autoyast partitioning fails with “Error configuring partitions. Try again.” This particular doc said I need to make sure there aren’t any existing partitions on the drives, so I went into the BIOS RAID configuration with control-I and deleted the BIOS RAID and recreated it, thus wiping out any filesystems that had been present. It doesn’t matter. I’ve tried telling autoyast to partition /dev/md126, /dev/dm-0, and also tried leaving out the device entirely to see what it would do…in all cases, it dies. If I give it a device to partition, the error in y2log is “Intermediate structure with index [”<whatever-I-gave-it"] does not exist. It says this even when the device I tell it to partition is /dev/dm-0, which definitely does exist during the install process. Has anyone else had success partitioning a BIOS RAIDed disk with autoyast, and if so, how?

Solution arrived from HPE/SGI guru Michael Skowvron. Blacklist the dm-mod module during autoyast install.

It’s always interesting to see the solution/workaround for an unusual issue. We appreciate your update.