Can't update Jupyterhub Chart because it requires Tiller >= 2.11

#1

Hi everyone,

I previously installed JupyterHub with their chart from https://github.com/jupyterhub/zero-to-jupyterhub-k8s but now I can’t upgrade it, because they require Tiller >= 2.11 and Rancher 2.2.1 only has 2.10.
Is there any way around this or if not, how can I migrate an existing deployed app from Rancher Catalog to classical Helm/Tiller?

Regards,
Moritz

#2

Okay, so I managed to successfully upgrade the Chart with Helm locally and Tiller in the Namespace.

Since the app is still listed as a deployed app in the Rancher UI, I hope that doesn’t do any side effects, since I will be managing it from my local Helm now… Or is there a way to delete it from Rancher Apps without actually deleting the release from the cluster?

Here’s what I did to make my local Helm find the installed release:
First I installed Helm and Tiller using the following section from the Helm manual: https://helm.sh/docs/using_helm/#example-deploy-tiller-in-a-namespace-restricted-to-deploying-resources-only-in-that-namespace
Of course, using the namespace the App is already deployed in and changing rules[0].apiGroups to ["*"] (in trial and error).
After doing that, helm list showed me the release I previously made through Rancher UI.
I could use helm get values to retrieve a config.yaml file for future customization.

Hope that helps others in the same situation, too.