cloud-init installation is failing on SLES15 Minimal Install

I installed SLES 15 with minimum installation and tried to install the cloud-init package.
Using the following command : zypper addrepo…oud:Tools.repo zypper refresh zypper install cloud-init zypper install cloud-init fails with : Loading repository data… Reading installed packages… ‘cloud-init’ not found in package names. Trying capabilities. No provider of ‘cloud-init’ found. Resolving package dependencies… Nothing to do. I search for cloud-init package running zypper search cloud-init S | Name | Summary | Type --±----------------------------±---------------------------------------------------±---------- | cloud-init | Cloud node initialization tool | srcpackage | cloud-init-vmware-guestinfo | A cloud-init datasource that uses VMware GuestInfo | package | cloud-init-vmware-guestinfo | A cloud-init datasource that uses VMware GuestInfo | srcpackage So the type here is srcpackage that’s why zypper install cloud-init failed. Then I tried zypper si cloud-init, This asks to install all the required packages separately. Is this a normal behavior? If so then where can I get the repos to be added in order to install the dependencies separately.

Hi and welcome to the Forum :slight_smile:
It’s not clear what your end goal is, if the system is registered, just add the public cloud module to install all the supported packages?


I had no troubles to install cloud-init from the mentioned repository. Can you share the output of zypper se -s cloud-init? And please format the output with the code tags, it’s difficult to read in your initial question.