Custom Cluster -> external etcd

Hi folks,

the settings described here about setting up a cluster with an external etcd seems to have no effect on Rancher created Custom Clusters YAML.
RKE up clusters working fine.

Is this a bug?


This issue seems to be still current (rancher 2.3.4).

Tried exactly same. Cluster initialisation never stops. There are no new keys in
the etcd specified in the cluster configuration… I suppose its ignored and rancher
waits for etcd nodes to register.

Same configuration with RKE CLI did fine.

Tried same with terraform. Rancher2 provisioner is unable to bring up the cluster, when cluster type has to be managed by rancher itself. External etcd is not supported.

I think its only consequent… When cluster has to be managed by rancher then as whole, not partially. External etcd is out of control for rancher (changing replica count for example). Makes sense. Imported clusters (provisioned by rke cli) are other topic… they are managed externally.

I think its a feature, not a bug. :wink: