D-Link DWA-132


Good day to all.

I’m a newbie for linux platform but I managed to install SLED 11 SP1 on HP Compaq Business dc7600. Also, I’m using D-Link DWA-132 to connect to my wifi. However, I’m unable to configure the usb dongle to work in SLED 11 SP1. The chipset of the device is RTL8192CU. I have tried search in Google but it just makes me more confuse. Appreciate if any Guru’s out there can guide me on this.

Thank you.

Welcome to SUSE and Linux in general!

SLED 11 SP1 has been end of life for some time now. As you’ve only just installed it I advise you do a clean install of SLED 11 SP3. SP3 has built in support for more hardware. If the dongle doesn’t work with SP3 do post again. But there really is no point starting out with Linux using a version that is already unsupported.

The SLED 11 SP 3 iso can be obtained from
You only need DVD 1.

Personally I would look for a different way to network the machine. In the limited experience I’ve had with USB wifi dongles I’ve found that they just aren’t much good. They’re better than no network, but that’s really about all they have going for them. If the PC has Ethernet, and the info I found online suggests it does, consider getting some network over power line adapters boxes. I use these http://www.tp-link.com/en/products/details/?categoryid=1658&model=TL-PA511KIT but many makes and models are available. They’ll be much more reliable than a USB wireless and getting an Ethernet connection set up is trivial.

Hi Jim,

I have updated the system to SLED 11 SP3 but the device is still not working. Upon checking using ‘lsusb’ the device is detected. Please refer below.

factory@localhost:~> lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 004: ID 2001:3307 D-Link Corp.
Bus 004 Device 002: ID 413c:1003 Dell Computer Corp. Keyboard Hub
Bus 004 Device 003: ID 413c:2010 Dell Computer Corp. Keyboard
Bus 004 Device 004: ID 0461:4d64 Primax Electronics, Ltd

Hi Jim,

Good day to you.

I have performed a clean installation on the system and install kernel-firmware after that. Now the device ‘D-link DWA-132’ has been detected and the device can identify my wifi network. However, the device unable to connect even tough i have tried many times with correct password.

Any help would be appreciated.

Thank you.

Hi Guys,

I manage to resolve the issue and it took me about a week. The good part is I’m not sure if I did it correctly.

Below are the steps

  1. Clean install SLED 11 SP3

  2. Install ‘kernel-source’ and ‘gcc’ from ‘Install/Remove Software’. Requiring root password

  3. Download ‘RTL8188C_8192C_USB_linux_v4.0.2_9000.20130911.zip’ from Realtek site.

  4. Extract the file in same folder, just right click on the folder and choose extract here.

  5. blacklist as per below in /etc/modprobe.d/blacklist and in /etc/modprobe.conf

    blacklist rtl8192cu
    blacklist rtl8192c-common
    blacklist rtlwifi

  6. To open blacklist. I did this gedit /etc/modprobe.d/blacklist in Gnome terminal

  7. To open modprobe.conf, I did this gedit /etc/modprobe.conf in Gnome terminal and off the driver as per below

alias driver-rtl8192cu off.

  1. Then move to driver folder. CD /Downloads/RTL8188C_8192C_USB_linux_v4.0.2_9000.20130911
  2. Then did this sh install.sh and reboot the machine.
  3. Once rebooted, the device is detected and able to connect and access internet.