Enabled project logging, saw "Logging is disabled at current cluster."

I tried to send all pods’ log to elasticsearch but after enabled I am seeing these warning

  • We will use fluentd to collect stdout/stderr logs from each container and the log files which exist under path /var/log/containers/ on each host. The logs can be shipped to a target you configure below.
  • Logging is disabled at current cluster.

How can I turn on logging on the current cluster?

rancher 2.3.5
k8s v1.17.2 on bare metal running Centos 7.7 started by rancher
docker 1.13.1

If you have an ElasticSearch cluster set up in your K8s cluster, you will need to click the Elasticsearch icon and fill corresponding information (endpoint, login info, etc) like this:


And in the bottom of the page there is a TEST button which you can test the connectivity. If it succeeds you might Save the setting to see if logs are being shipped or not in Kibana.

I just managed to set up ECK and let Rancher pump logs to it which I can then see something in Kibana. Should you need more details please just let me know.

I found out how to turn on project logging (That always confused me). This is done via Cluster -> Logging

I setup a elasticsearch single node cluster and kibana in the same k8s cluster. I am able to setting up rancher logging to it.

However, I only see test/validation in log. I think docker on CentOS7 log using journald which rancher’s fluentd is not monitoring the same location. Do you know how to fix?

found how to fix docker to log to /var/log/containers