error:-Insufficient color depth to display installation pane

Dear All,
I am new to Linux. We have purchased one software in our compony. But whenever I try to install, it is giving error that
error:-Insufficient color depth to display installation panel.

Can anybody let me know how can I set the color depth in SUSE linux manually?
sometimes it is also giving error Xlib: Connection to “0:0” refused by server
Xlib: No protocol specified.
(I am not logging in remotely or X System)

I request help from all of you.


What graphics card are you using?

Please post the output from;

hwinfo --gfxcard

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 3.0.38-0.5-default
up 2 days 18:30, 3 users, load average: 2.45, 2.45, 2.38
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

Please find below output:-

86: PCI 600.0: 0300 VGA compatible controller (VGA)
[Created at pci.318]
UDI: /org/freedesktop/Hal/devices/pci_10de_6dd
Unique ID: vTuk.u9TLOvrwYdA
Parent ID: 3hqH.ZWaznjlqOZ9
SysFS ID: /devices/pci0000:00/0000:00:03.0/0000:06:00.0
SysFS BusID: 0000:06:00.0
Hardware Class: graphics card
Model: “nVidia VGA compatible controller”
Vendor: pci 0x10de “nVidia Corporation”
Device: pci 0x06dd
SubVendor: pci 0x10de “nVidia Corporation”
SubDevice: pci 0x0780
Revision: 0xa3
Memory Range: 0xf4000000-0xf5ffffff (rw,non-prefetchable)
Memory Range: 0xe8000000-0xefffffff (rw,prefetchable)
Memory Range: 0xe4000000-0xe7ffffff (rw,prefetchable)
I/O Ports: 0x4000-0x4fff (rw)
Memory Range: 0xf6000000-0xf607ffff (ro,prefetchable,disabled)
IRQ: 11 (no events)
I/O Ports: 0x3c0-0x3df (rw)
Module Alias: “pci:v000010DEd000006DDsv000010DEsd00000780bc03sc00i00”
Driver Info #0:
Driver Status: nvidiafb is not active
Driver Activation Cmd: “modprobe nvidiafb”
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #58 (PCI bridge)

Primary display adapter: #86

Please help. I am stuck.

Hi gajubhai,

I’ve followed this thread, but had difficulties determining what actually goes wrong. You’re new to Linux, so you’re not into the details (yet :wink: ), which makes giving precise information difficult. I’ll have to try asking the right questions :slight_smile:

  1. If this is mission-critical and has to be worked around quickly, you might be faster off doing a text-based install, rather than graphical.

  2. Text mode is (as far as I have experienced) an automatic default during installation - if graphical mode fails, it uses text mode YaST. Does this happen in your case?

  3. It is unclear where exactly the error occurs. The normal progress is to boot the installation media, which gives you a selection menu (I’ll call that “grub”). The default entry, selected when no other input is made, is (as far as I recall) to install SLES. Then the installation system is loaded (giving text mode messages, then switching to a graphical mode) and the installation tool (“YaST”) comes up in graphical mode (or falls back to text mode). There is, iirc, a reboot during installation, getting you back to YaST once the reboot completed (in graphics mode, too) and after installation, you can reboot the system. Where in this process does the error message appear? Is it something output the console as some sort of “stray error message” or is it displayed in some form of message box or accompanied by a message, something like “An error has occured. The actual error message was:…”?

The error message(s) themselves could point to multiple error sources - it could be as simple as an X server (“graphics mode”) that won’t start due to some configuration problem. Depending on when this occurs, there are different ways to approach this situation.

With more information, we may be able to get things running :slight_smile: