Hi folks,

just copied /etc/sysconfig/network/routes from an existing box based on SLES11SP3 to the new box based on SLES12SP2

Did syntax change?

Can’t activate the config.

Tried several times:
yast lan
vi /etc/sysconfig/network/routes

I only get a route to work by adding it via route add on command line. The bad thing is, it does vanish after reboot.

The new config won’t do, neither by issuing a service wicked restart nor rcnetwork restart nor by rebooting…

What does the trick to activate the routes needed?

changed to CIDR notation, but no success.
Strange thing:
I’m connected via the eth0 interface - if I do a query wicked show all it says device-not-running


If you know how to do this in Yast, one of the feature of SLES 12 by
default is the use of BtrFS for the main filesystems, which means you can
cause a change in whatever way (Yast included, and done by default) and
then ask the system what changed during that change using ‘snapper’ or
Yast’s plugin for snapper. Finding how xyz tool works, then, is trivial
because the filesystem keeps before/after snapshots for you that you can
compare directly. For example:

#Get a couple of snapshots to compare, for example from your
#Yast operation:
sudo /usr/bin/snapper list

#Comapre two snapshots, preferably with few changes within, in this
#case comparing snapshot 1234 with 1235:
sudo /usr/bin/snapper diff 1234..1235

As mentioned, Yast also has a component that lets you graphically compare
snapshot data.

Good luck.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below…

No need to snap. Just want the network config up and running…

Thanks aw

I’m not sure my meaning, or maybe tone, came through properly. If you
felt I snapped, as in spoke harshly, please understand that was not my

Whether or not the ‘routes’ file syntax or use has changed between SLES 11
and 12, I do not know, as I’ve never tried modifying it directly, but
instead have always setup routes (rarely, admittedly) via Yast which has
worked well.

Assuming you can modify the system in a way that is persistent across
reboots using Yast, you should be able to determine what the right change
is for adding a given route, whether that’s modifying the
/etc/sysconfig/netowrk/routes file itself, or something else. I could
setup another route on a test box and let you know, but my home network is
pretty simple/flat/basic so while I could define them, I would not have a
way to test them to ensure they work despite the configuration changes.
Still, what I would do is use Yast to make the change, and then look at
the snapshot difference automatically captured by Yast and see which files
change, and how. I could then rollback the filesystem to before the
change and try again with the manual (file) changes and see if the changes
still work and are persistent across reboots.

Good luck.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below…