First boot - "HDMI / DVI out of range"


Downloaded the image and burned it to SD-card, started first boot with monitor (LG W2442PA-SF) and keyboard attached. See Grub screen, efi stub, subsequently some Dmesg stuff, ending with “switching root”, then screen turns black and after a few seconds the screen throws an error:


depending on which cabel (HDMI-HDMI or HDMI-DVI) I use.

Had this error in the past with other monitors and upstream opensuse ARM, could never resolve it, but with opensuse I could log in via ssh, set up VNC server and use the Raspi headless, as usual. As SLES wants to go through the usual setup (time zone, passwords), I can’t access ssh here.

So actually the install is dead after first boot.

Any way around that?

Kind regards


Are you connecting directly to the monitor or are you using a KVM switch? I’ve seen that type of issue with earlier SLES releases when using a KVM switch.


No KVM, simply cable. Cable(s) checked, even other monitor checked… The only aarch64 suse I can get working here on Raspi 3 is that by Stefan Brüns

I use the one with XFCE, working fine! The other aarch64 images of openSUSE gave me the same error in the past.

PS: However, the monitor has a built-in switch for the VGA/HDMI/DVI input! Might it be related to this?

PPS: I tried the XFCE aarch64 openSUSE again

…same error, HDMI out of range.

[QUOTE=suse_rasputin;35193]PPS: I tried the XFCE aarch64 openSUSE again

…same error, HDMI out of range.[/QUOTE]

So graphics stop working for you as soon as Linux switches to the accelerated “vc” drm driver. Since we have a working efifb fallback driver, you can just blacklist vc and still get usable enough graphics. I’m not sure how you can do that from the kernel command line, but I’m sure you’ll figure it out :).

…or not. :wink:

I will stick to Stefan Brüns aarch64 TW till it’s fixed in the future.

So I have a slightly strange widescreen Dell monitor which displays nothing on first boot and then eventually gives me an out of range message.

The way I overcame this to get at least the boot screen up is to edit the config.txt on another machine and to add an entry “hdmi_safe=1”

Taken from this page

“hdmi_safe Use “safe mode” settings to try to boot with maximum hdmi compatibility. This is the same as the combination of: hdmi_force_hotplug=1, hdmi_ignore_edid=0xa5000080, config_hdmi_boost=4, hdmi_group=2, hdmi_mode=4, disable_overscan=0, overscan_left=24, overscan_right=24, overscan_top=24, overscan_bottom=24”

This allows me to get the system configured so that I can then run it headless and get it on the network.

…same “HDMI out of range” with LEAP 42.2 for rapsi 3 from here:

I added “hdmi_safe=1” to config.txt on the efi partition of the LEAP image after copying over to the SD-card. Same result, “HDMI out of range”…

Wrong config.ttxt? :-/

I experienced this issue upon my initial setup. I found a partial workaround of using a nearby TV as a monitor, this allowed me to get past the initial configuration so that it could have it run headless.

If anyone is experiencing this I would try any spare Monitors/TVs you have in the vicinity and see if you can get a picture using a different display.