Flatpak permission denied on install

looking for help on flatpak

Warning: Could not unmount revokefs-fuse filesystem at /var/tmp/flatpak-cache-07HK81/org… Failed to execute child process “fusermount” (Permission denied)
… repeats for all packages requested to install as above …
Error: Could not unmount revokefs-fuse filesystem at /var/tmp/flatpak-cache-07HK81/org…: Failed to execute child process “fusermount” (Permission denied)
error: Failed to install org.kde.Platform: Could not unmount revokefs-fuse filesystem at /var/tmp/flatpak-cache-07HK81/org…: Failed to execute child process “fusermount” (Permission denied)

Flatpak worked fine yesterday, also started throwing this warning then error (blocking all installations) after installing of just a few flatpack applications.

could be policy kit related ?

@JLT Hi and welcome to the Forum :smile:
So is fusermount installed? You’re install flatpaks as your user not system? You might need to add the -v option to your install to see some more verbose information.

1 Like

thanks, using -v works indeed, not enough disk space reported
stupid i had to write a post to learn this but happy with the response

oh, and, yes, fusermount is not allowed for this user indeed

learning SLED after many years with Debian, then a stint with Rocky Linux
experience is quite good thus far and what i encounter keeps making sense

I guess I’ll have to figure out why SLED is blocking users from using fusermount, this is odd. It seems to be set by /etc/permissions… files which are new to me.

@JLT Hi, do you have Flatseal installed? Have you looked at any limit adjustments in /etc/fuse(3).conf?

flatseal is unknown to me, also could not be found in SLED

installing flatpak as user, using the -v option shows output mostly similar to the output shared before

installing as root does work (obviously, since permission denied notifications)

@JLT it’s a flatpak, flatpak --user install com.github.tchx84.Flatseal more information at https://github.com/tchx84/Flatseal

thanks for the helpful comments, what i wonder about is why i’d require to do any of that since this is a fresh install and nothing’s been change for flatpak

typically i avoid any of the flatpak, snapd, appimage and such because of the blind-sided-approach this invokes, maybe i do best to stick to that, it’s supposed to be easy, this is broken ?

@JLT AFAIK by default the flatpak has access to nothing, file system etc… I only run on MicroOS.

What flatpak are you installing?

@malcolmlewis1 I’ve just the os and use the software store to install things, so i’m not doing anything really, just doing what is available out of the box.

I’ve installed flatpak on Rocky Linux without issue, also as user if i remember well. That’s why flatpak, right ? to be able to install as user ?

@JLT yes, I would only do at a user level, not system… I run a script to install a few different ones on MicroOS.

   # Add flathub repository as user
   flatpak --user remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo

   # Install flatpak applications
   flatpak --user install --noninteractive flathub com.github.tchx84.Flatseal
1 Like

thanks, i’m perplexed i’m required to add the flatpak repo for per user also

I don’t get why i paid for an enterprise license to have to go and fix things, many packages also throw an error on dependencies not existing and such ( have to admit i added opensuse repo too)

So far, Suse SLED does look mature but there’s many quetionmarks, like using LUKS1 for encryption, not having compliance profiles enforced on install etc. It will take time for me to catch up.

@JLT That’s just a recommendation, there is nothing stopping you from adding from a global (–system) standpoint at this time.

thanks, zero issue with the recommendation, a good one at that.

Just complaining a bit of the limitations and requirements with SLED after having paid for it.
Thanks anyway, it work now.

1 Like