FreeNAS - VM Rancher | Host is Disconnected

i have a FreeNAS with ein VM with Rancher, i have also a Host but it is Disconnected.
How to reconnect it?
How it happen to be disconnected?

a Plex Docker insyde is working well.

have a nice day

after a couple of time to restart Rancher - the Host is connected.
But the question is still there why the Host disconnect and how to reconnect without to have to restart the VM
have a nice day

any Help,
sometimes i also just lost the Host, but the Plex Docker insyde would be still working.
any Help
have a nice day

The agent on the host opens a Websocket connection to the server container. Disconnected means the server doesn’t see a working connection from that host. So the networking between the two is breaking periodically, the IP of the server is changing and the host is still trying to connect to the old one, the agent container is dying (maybe OOM killer choosing it), the CPU is overloaded enough that the container can’t get a ping out every few seconds, or something along those lines.

1 Like

thanks for your feedback, there is only one Plex-Docker running, and also running/working without "host"
so is there a way to “call” it back to live without to install something and loosing the running Docker?
have a nice day

SAD not to get more help with this!

I’m having the same problem. This post explains what is happening, but does not tell us how to solve the problem. Please help us to solve the problem.
Fortunately in the original poster’s scenario, he is still able to access his plex docker. But in my case, I can’t access my docker. The container shows as running, but I can’t access it’s UI via the configured port. I’m suspecting the problem must have something to do with the Host showing as Disconnected.

might be worth mentioning that I have configured my RancherOS to use a static ip as indicated here.

The host shows as follows:

The last time it showed as connected and all was running well, that IP Address I circled in red was the IP Address of the server (, which is now configured as the static IP Address as per the reference documentation). How do I get the host to connect on this address?

To specify the IP which is used, you can add -e CATTLE_AGENT_IP=ipaddress to the docker run command to run the rancher/agent container.

Thanks @superseb. How do I do this on an existing host? Or do I have to create a new host and apply this setting at creation time?
EDIT: nevermind, I found the answer here.

Well it seems the above step ended up leading to all kinds of bad…
Now my Host shows as Active, but none of the service containers running on it are stable…see this screenshot:

The system services keep changing state…Starting…In Progress…None…Starting…InProgress…Error.
That timeout error is “Timeout error getting IP Address”.

And what’s that new Standalone Container called hungry_leaky?!? That wasn’t there before.
The CrashPlan container failed startup with an error about being unable to access the Volume, which makes sense if the nfs container is cycling through the above-mentioned states.

I’m thinking it is time to trash this host completely and start afresh with a new host…perhaps my idea of setting a static IP AFTER creating a host was a bad idea.

Will provide feedback later…

i do still have the problem

how to reconnect it - and yes a Plex docker ist still running, but would need a update