fwupd can not be updated to latest

Hi hope anyone could help me with this error…
I encountered this error during firmware update >> “cannot handle firmware requirement xxxx-xxxx-xxxx-xxxx-xxxx” with fwupd version 1.0.9 but SLED says it’s the newest version already… I tried force updating via snapd but encountered the attached errors…
when tried to update firmware…

What are you running SLED on, what release of SLED?

I see the following on SLED 15 SP1;

fwupdmgr refresh
Fetching metadata https://cdn.fwupd.org/downloads/firmware.xml.gz
Downloading…           [***************************************]
Fetching signature https://cdn.fwupd.org/downloads/firmware.xml.gz.asc

fwupdmgr get-devices
HP Notebook System Firmware
  DeviceId:             xxxx
  Guid:                 xxxx
  Guid:                 xxxx
  Plugin:               uefi
  Flags:                internal|updatable|require-ac|registered|needs-reboot
  Version:              15.48.0
  Icon:                 computer
  Created:              2020-06-02

I installed SLED 15 SP1 as well… firmware update that requires version higher than 1.0.9 has this error… I need my fwupd updated to a higher version… it seems SLED does not support that… or any special procedure to be able to do the update? please advise… thank you very much…

@Katherene I see a higher version (at present 1.2.11) is in the next SP release in beta testing at present, perhaps in the interim, run a live openSUSE Tumbleweed rescue USB to complete an firmware update.

hi @malcolmlewis oh… thank you vey much for the suggestion… I will ask our team if this is OK for our unit testing…

@malcolmlewis do you know when is the target release with higher fwupd version?

@Katherene I see the plan is for end of July for SP2: https://suse.com/betaprogram/sle-beta/ that may move…

@malcolmlewis thank you very much for the information!