Hang during boot doing "modprobe -q microcode"

I am building machines using autoyast. Since yesterday afternoon, machines are building almost to completion, and then during the final boot (I think it does clean-up during this boot as well), it reaches this point:

Re-Starting syslog services done
Checking CPU… upload Intel microcode

and goes no further. Attempts to reset the machine again reach this point and hang. Attempts to rebuild again with autoyast again reach this point and hang. I am seeing this with multiple machines now. These machines are irretrievably stuck now.

It looks like the above message is printed to the console in the course of running /etc/init.d/microcode.ctl . This is the relevant piece of the script:

    if [ -e /lib/firmware/intel-ucode/${cpu_family}-${model}-${stepping} ];then
        rmmod microcode >& /dev/null
        echo -n ".. upload Intel microcode"
        /sbin/modprobe -q microcode

Thus my hunch that the hang is in the modprobe command.

Has anyone else seen this or have any idea what is causing this and how to fix it?

thank you -


It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

These forums are peer-to-peer, best effort, volunteer run and that if your issue
is urgent or not getting a response, you might try one of the following options:

Be sure to read the forum FAQ about what to expect in the way of responses:

If this is a reply to a duplicate posting or otherwise posted in error, please
ignore and accept our apologies and rest assured we will issue a stern reprimand
to our posting bot…

Good luck!

Your SUSE Forums Team

Have you tried other hardware, or other virtual environments (if virtual)?

Which version and Service Pack (SP) of SLES?

Which virtualization environment or physical hardware?

Could you post your Autoyast file? How did you create it, and has it, or
one like it, worked in the past for you?

If you do a regular install of SLES does this happen? If not, and you run
that command, does it then happen?

Good luck.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below.

If you want to send me a private message, please let me know in the
forum as I do not use the web interface often.