Hardware change: Driver update fails when installing rpml

Hello everybody!
I am getting following internal system error:
[PK_TMP_DIR|dir:///var/tmp/TmpDir.vGXU83] Repository already exists.
when I install the RPM-File.
When I look at /var/temp there is no TmpDir.vGXU83 .

It’s my third day using unix so it can be something simple/stupid.

Installation details and history:
[]1. First I did a successful Installation of 64bit SLES on a USB drive attached to an HP Probook 6570b Laptop without any problem. Even driver for Fingerprint sensor got installed at first time, everything worked.
]2. I changed Mounting methods for all Linux partitions at fstab-options and at Grub from device by disk-ID to Device by name.
[]3. Than I attached the USB-Drive (or a clone) to a HP Probook 6560b:X-Windows started successfully, - same speed/no delays, Ethernet works, but not WLAN, fingerprint sensor, and probably some other devices.
At HW-Info I can see that correct WLAN device got detected(Broadcom 4313, but no driver section indicates that no driver got installed.
HP6560b has a windows installation on first HD so there is a guarantee that WLAN devices works without any issues.
Assumption: HP offers unix-drivers for SLED (Desktop), I assume SLES and SLED are based on same Kernel and SLED is 64bit, too. So I assumed that I can use the SLED Driver for SLES.
]4. I have no access to HP6570 at this moment, but when I downloaded driver for for 6560b I recognized that it differs to to driver for 6570. Nevertheless it can be possible that vendor of device/driver is always same (HP or Broadcom) and that there is only a small difference in version of device and driver (RPM-file).
[]5.Driver tar-file for 6550 contained two rpm-files:broadcom-wireless-5.101.1002.400-1.i586.rpm and broadcom-wireless-kmp-pae-5.101.1002.400_2.6.32.12_0.7-1.i586.rpm. Tar-file got extracted to personal folder.
]6. When trying to install one of these rpm-files I got every-time same error, just the name of the repository is changing every time. When I try to install a new driver for fingerprint sensor in same way, I am getting the same error.

Thanks in advance and best regards,

What do you repositories look like?

zypper lr

Check down in /etc/zypp/repos.d/ for _tmp dirs, but if it exists in the above output use zypper rr to remove.

Thanks, Malcolm!
In /etc/zypp/repos.d/ I found 3 files/repos: two different Sles… entries and PK_TMP_DIR.
Owner root can read and write, Group root and all other can only read.
Zypper lr says same: All three repos have the value active and PK_TMP_DIR has the value aktualisieren = yes.
Opening PK_TMP_DIR it has an entry like this: baseurl = var/tmp/Tempdir.M39y39

I am currently at home and on Windows, because my LAN-cable is not long enough.
So I also don’t have access to Unix file-system (ext) and from Suse I didn’t have access to NTFS.
Until now I don’t know how to install FUSE or another option to access NTFS file system. So I can’t send you the copies of these files or the Zypper-output.

I assume Zypper rr will remove all three entries, but keeping the entry for SLES DVD would be nice.
Nevertheless I will execute Zypper now.
I will tell you the result in short time.

Bye for now,

I came to conclusion that I was trying to install the driver as common user from nautilus, but not as root. So it was not possible to change or overwrite the file PK_TMP_DIR in /etc/zypp/repos.d/ .
I didn’t execute ZYPPER RR, but used Software Repositories in Yast and removed PK_TMP_DIR. As result the file PK_TEMP_DIR at /etc/zypp/repos.d/ got deleted, too.
Then I added the a sub folder of my /home containing the two rpm-files of HP Driver Package for WLAN of HP Probook 6560b.Now I was able to install both RPM-files via Yast Software Installation.
First I installed broadcom-wireless-5.101.1002.400-1.i586.rpm without problems and errors, but at HW-Info no driver got assigned to Broadcom WLAN.
When Installing broadcom-wireless-kmp-pae-5.101.1002.400_2.6.32.12_0.7-1.i586.rpm I got a conflict message like this (translated from German):
kernel(pae:MM_SLAB) = 884143f7bb3b29db, required by broadcom-wireless-kmp-pae-5.101.1002.400_2.6.32.12_0.7-1.i586.rpm, is not provided by any repository.
When i choose ignore the RPM got installed, but no driver got attached at HW-Info to broadcom WLAN.
If I understand the information provided by YAST Software Installation => Repositories => Technical data correctly then there is an alternative driver existing in SLES 11 with same name and Version and same size.
I am not sure if this alternative driver is just part of SLES 11 DVD or if this driver is already installed, -but not working.

Side effect:
I did the changes to Repositories and installation of new driver on the cloned USB-drive attached to Probook 6560b.Both USB-drives, original and cloned, had been working fine at both Laptops.
When I now attache this drive to Probook 6570b of original installation the boot procedure fails: The SUSE Linux Enterprise Server start picture got displayed for a second, I assume that video frequency then get changed, and after this the screen is flashing in white and green at very high frequency. After 3 minutes I did a hard switch-off.
This cloned drive still works fine at 6560b, so I am just using this. And yes, original drive is still working fine at both computers.
The only difference between both drives is the removed repository PK_TMP_DIR and the added - but not working - WLAN-Driver.

I have still no sufficient understanding how SUSE manage device drivers in general,especially how these repositories are working and got used. Probably I am not installing the new driver provided by HP in correct way.
Perhaps this additional driver is not even necessary. I assume, if I would install a new SLES 11 on my Probook 6560b, then I would get all driver for all HW installed by SLES installation program directly at first turn of installation without any additional drivers from HP.

I assume something is wrong in my approach. Perhaps I am not aware of an important functionality, something like the Device Manager of MS Windows.
Until now I found nothing helpful in the huge amount of documentation for SLES.
Suggestions for all kind of books and documents are welcome.

Thanks in advance and best regards,

In most cases it’s probably better to build a driver like this locally from the src rpm, then it will be built to match the running kernel. I normally grab the version from packman and use that, if in fact you do need it, or in some cases it’s just missing firmware, which can be found via dmesg.

Suggest have a read of the wireless stickies here for more info;

The broadcom-wl driver src rpm can be obtained here;

Then as root user install;

zypper in kernel-source kernel-syms linux-kernel-headers patch make gcc rpmbuild


Then as your USER, rebuild the rpm

rpmbuild --rebuild <name_of_src_rpm>

Then you can install the built rpms as required as root user with zypper